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Preface 

This tutorial describes the basic features of FamLink2. The current version of the 
tutorial is based on version 2.3 but should also work reasonably well for any 
versions above 2.0. Please note that version 1.16 and below contain a 
completely different interface. We refer to FamLink as FamLink2 to distunguish 
from version 1.16 and below. 

 

For a more comprehensive description and theory we refer to the manual available 
following links at https://famlink.se or publications listed at the indicated link. 
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https://famlink.se/


Introdution 

3 FamLink - Tutorial 

FamLink2 is a freeware without any string attached. The latest version and other files 
(databases etc) can be downloaded at https://famlink.se. The core computations 
relies on two different implementations, one for all computations where 
mutations are considered (only available for pre-defined pedigrees 1-24) and 
one for all other pedigrees and user-created pedigrees. The former is also 
implemented in FamLinkX for X-chromosomal STR/SNP markers. Note that 
FamLink2 can handle both SNP and STR markers, while some features curerently 
only works with SNP markers (genotype uncertainty).  

 
This tutorial will describe the basic steps to running FamLink2 as well as some 

advanced features. At the end of some section we have listed a ‘How to’ laying 
out details on how to perform a function in FamLink2. 

 

A comprehensive manual will soon be published with details on algorithms and 
implementations. 

 

https://famlink.se/
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1. Basics 
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Input file: tutorial-Ch1.sav 

https://famlink.se/Files/tutorial-Ch1.sav
https://famlink.se/Files/tutorial-Ch1.sav
https://famlink.se/Files/tutorial-Ch1.sav


Example used to introduce FamLink2 
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Consider 
 
• H1: 1 and 2 are full siblings 
• H2: 1 and 2 are unrelated 

 
With marker data listed below 

 

We next explain the basic steps to compute the LR in FamLink 

Marker Chromosome cM 
position 

Allele 
freqs 

DNA data 
for 1 

DNA data 
for 2 

rs1234 1 1 G=0.2, 
T=0.8 

G/G G/G 

rs12345 1 1.5 A=0.4, 
G=0.6 

A/A A/A 



Four basic steps 

FamLink - Tutorial 7 

1. Creating a database. Input of database, i.e., allele frequencies, etc. 
2. Define hypothesis.  Wizard to choose pedigree (or create your own) 
3. Case DNA data. Marker data.  
4. Results. Do calculations 

 



Step1: Database 
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• Click ‘Add’ to enter a marker. In the new window, enter as shown. 
• Similarly for next marker rs12345 with alleles A and T, frequencies 0.4 and 0.6. 
• Automatic sorting of markers will be performed. 

Enter the database window through File -> Frequency database 



Step 2. Defining hypothesis 
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• Select ’Full Siblings’ from the list. Press Next 
• Create your own pedigree if it is not in the list 



Step 2. Select alternative hypothesis 
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• Select ’Unrelated’ from the list. Press Next 
• Create your own pedigree if it is not in the list 



Step 3. Case data 
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• Select each person from the top-most dropdown list. Select marker 
and edit the alleles, genotypes are updated immediately when 
selecting an allele. We can also import data from file using the ‘Import 
data’ button, described later in this tutorial. 



Step 4. Results 
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• Press ‘Calculate’ to compute the likelihood and LRs. Highlight the Full 
Siblings hypothesis to reveal a LR of LR (Exact)=45.1624 in favor of full 
siblings and LR (Unlinked)=27 if linkage is not accounted for. LR 
(Merlin) is computed externally in Merlin and may differ slightly from 
FamLink. Merlin is by default turned of (see File->Settings). 



Shortcut: Quick analysis 
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All versions of FamLink has contained a shortcut to perform calculations 
for any number of linked markers. The Quick analysis feature involves 
using a Familias type file (.fam) with markers, DNA and pedigrees 
defined. Through Tools -> Quick analysis one may then analyse the 
Familias file in FamLink and provide the user with an adjusted LR for 
linkage between any markers. The caveat is that this feature does not 
consider mutations, subpopulation structure or other complications. 
In addition, we require a map like file with genetic positions of all 
markers we want in our analysis. 



2. Complications 
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Mutations 
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• FamLink2 can model mutation for some pre-defined relationships. Those 

are all listed in File -> Settings, see below. 

Mutations are mostly important if 

STR markers are part of your panel 

of genetics markers and if there are 

relationships where inconsitencies 

can lead to zero likelihoods. 

 

Note: FamLink2 uses an alternative 

(slower) algorithm for the 

relationships listed to the left in 

order to model mutations. 



Mutation models in FamLink 
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- Simple model 
Each mutation has an equal probability of occurring. Appropriate for fast 
computations (e.g. complicated pedigrees and DVI) as well as for SNP markers. 

- Proportional to frequencies 
Each mutation has a probability which is proportional to the frequency of the 
allele we are transitioning to. A low frequency will yield a low mutation 
probability. Appropriate for testing of statistical properties of calculations. 

- Stepwise model 
The traditional stepwise model where the probability depends on the number of 
steps from the original allele to the mutated allele, decreasing probability for 
longer repeat mutations. Appropriate for STR markers without microvariants. 

- Stepwise stable model 
The traditional stepwise model where the mutation probabilities have been 

adjusted to create a stable mutation matrix. Appropriate for testing of statistical 
properties of calculations. 

- Extended stepwise model (RECOMMENDED) 
The most complete stepwise model, where both exact repeats as well as 
microvariants are accounted for. Appropriate for all STR markers. 



Theta correction 
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• FamLink2 allows the user to specify a Fst/theta correction factor for each 

population 

• The setting is accessed through File -> Frequency database 



Creating custom pedigrees 

• FamLink2 allows the user to create completely custom 
pedigrees which will invoke computations without mutations 

• To create a custom pedigree go to Tools -> Select pedigree -> 
Create/Edit pedigree.  
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We will create a custom pedigree for two 

double first cousins, see illustration to the right 



Creating custom pedigrees 
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We will create a custom pedigree for two 

double first cousins, see illustration to the right 

 

The recipe is to, 

1. Add all persons/individuals needed to 

define the pedigree 

2. Add all relations (parent/child), see below 



3. Plotting 
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What is       ? 

• A framework for statistical and numerical computing 

– calculator 

– flexible plotting 

– large core of functions for data handling and numerical analysis 

– programming language 

– external packages 

•anyone can make one 

•thousands!  

 

• About R: 

– it's freely available from https://cran.r-project.org/ 

– it's widely used 

– it can do anything (but it may not be easy) 
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https://cran.r-project.org/
https://cran.r-project.org/
https://cran.r-project.org/


Used in FamLink mainly to plot pedigrees 

R is mainly used to plot created pedigrees in FamLink2. To access the functions of an external 
library, exemplified with FamLink below, you must: 
 

• install the package, this done only once:  
⮚ install.packages(\ "https://FamLink.name/RFamLink/FamLink_2.5.zip\ ", repos = NULL, type = 

\ "win.binary\ ");  #(internet connection needed)  

 

• load it into R every new session: 

⮚ library(FamLink );  # previous download need to be ok, check for errors 

 

• R can also be used to plot various output from FamLink, e.g. from blind searches or from 
simulation (see next section 4. Simulations) 
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Plot pedigrees – How to 

1. Create a custom pedigree through Tools -> Select pedigree -> Create pedigree 
2. Define all the persons needed to define the pedigree (see sections 1. Basics and 2. 

Complications). We will define a double first cousins relationships, see below 
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Plot pedigrees – How to 

1. Create a custom pedigree through Tools -> Select pedigree -> Create pedigree 
2. Define all the persons needed to define the pedigree (see sections 1. Basics and 2. 

Complications). We will define a double first cousins relationships, see below 
3. Define all relations, see below.  
4. Use the ’Plot in R’ button and copy-paste the code into an R window. 
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4. Simulations and generating data 
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Input file: tutorial-Ch4.sav 

https://famlink.se/Files/tutorial-Ch4.sav
https://famlink.se/Files/tutorial-Ch4.sav
https://famlink.se/Files/tutorial-Ch4.sav


Simulations and generating data 
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• FamLink2 provides two ways to generate data 
 

Alternative 1: Generate data for pairwise relationships 
 
Alternative 2: Generate data for any relationships for any number of persons 
 
 
The first alternative may be slightly faster due to more efficient implementation and also 

provide the possibility to model admixed ancestry for founders. However, alternative 2 is 
more general allowing any pedigree to be defined and tested. Alternative 1 also allows 
the output of IBS measures, e.g. KING robust kinship coefficient and other metrics. 



Simulations and generating data – How to 
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• Alternative 1 – Pairwise relationships 
 

Open the frequency databse linked to in the first slide of this section. Then open the 
generate data feature through Tools -> Generate data. See below 

Settings include 

Number of profiles = Number of simulations 

Seed = Random start number 

Ancestry settings: Decide if founders should be  

drawn from two different populations 

Relationship: What relationship to simulate: Choosing 

unrelated will not result in any likelihood computations. 

Computations: Compute summary statistics 

 

Note that one can simply generate data without 

performing any computations. The data can later be 

viewed in Excel/R or similar software. 



Simulations and generating data – How to 
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• Alternative 1 – Pairwise relationships 
 

Open the frequency databse linked to in the first slide of this section. Then open the 
generate data feature through Tools -> Generate data. Use default settings but change 
the Relationship to Full siblings and select to compute both likelihood statistics. Press 
’Generate’. Note that the IBS statistics, i.e. shared segments and kinship coefficients do 
not work well with only two markers. The results will be saved to a file. Later we will 
show how to plot these data in R. 



Simulations and generating data 
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• Alternative 2 – General relationships 
 

Open the frequency databse linked to in the first slide of this section. To simulate data, go 
through Tools -> Select pedigree. Then select Full siblings as the main hypothesis and 
press ’Next’. Select Unrelated as the alternative hypothesis and ’Next’. Press ’Next’ again, 
without defining/importing any DNA data. Now press Simulate to open the simulation 
dialog. Illustrated below. 



Plotting simulations. Data organised for R. 
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• Plotting and further analysis can be done in Excel (not explained here). 
• We rather use R and save the above file as a tab delimited file called Sim.txt 

⮚ Variable names need to comply with R requirements  
(for instance, ‘TRUEPED’, not ‘TRUE PED’) 

⮚ Value of variables also need to comply with R requirements: 
We can use e.g. ‘H1.father’ but not say ‘H1:father’ or ‘H1 Father’. 

 



Plotting simulations. Using R 
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dat = read.table("http://FamLink.name/tutorial/Sim.txt",  header = TRUE) 
summary(dat) # Check data 

dat = dat[dat$TRUEPED == "H1", ] #Extracts data for hypothesis H1 

summary(dat) 
logLR = dat$logH1 - dat$logH2 # Calculates log (=ln , i.e., base=e) of LR 

hist(logLR, xlab = "logLR", ylab = "count",  main ="logLR (lnLR)")  
boxplot(logLR, ylab ="logLR") 
LR = exp(logLR) 
hist(LR, xlab = "LR", ylab = "count ", main ="LR")  
boxplot(LR, ylab ="LR") 

• We provide an example for plotting in R, with the file already in it’s correct format. 
• You can copy and paste the following commands in R, but internet connection is 

required since the file of interest is in the link of the first command line:  



Plotting simulations 
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# First, density plot (log LR distributions), running this code requires an internet connection 

dat = read.table("http://FamLink.name/tutorial/Sim2.txt", header = FALSE, skip=5) 
plot(density(log10(dat$V1)), xlab= "log10 LR", ylab= "Density", col=1, lwd=2, main="", xlim=c(-20,20), ylim=c(0,0.2)) 
points(density(log10(dat$V2)), col=1, lty=2, lwd=2, type= "l") 
legend("topright", c("H1: Siblings", "H2: Unrelated"), lwd=2,lty=1:2) 
# Next exceedance plots, i.e. the probability to exceed each threshold given each hypothesis 
dev.new() 
threshold <- exp(seq(log(0.01), log(20), length.out=1000)) 
eh1 = eh2 = threshold 
for (i in 1:1000) { eh1[i] = sum(log10(dat$V1)>threshold[i])/1000; eh2[i]= sum(log10(dat$V2)>threshold[i])/1000; } 
plot(x=threshold, y=eh1, lwd=2, ylab= "Exceedance probability" ,xlab= "log10 Threshold" , type= "l") 
points(x=threshold, y=eh2, lwd=2, lty=2 , type= "l") 
grid(); legend("topright", c("H1: Siblings", "H2: Unrelated"), lwd=2,lty=1:2) 

• Data saved to file Sim2.txt and processed as shown below 
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Plotting simulations 
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Meaning 

After 1000 simulations: 
-  the values of the LRs if H2 is true range 
from 10-20 to 105 (more or less) 
-  the values of the LRs if H1 is true range 
from 10-5 to >1020  
 
The probability that LR(unrelated) is 
larger than LR(sibs) is fortunately small, 
and estimated in R to be 0.002 (2 of 1000 
simulations): 
 
sum(dat$V2 > dat$V1)/1000 
 

Data for plotting: 
http://FamLink.name/tutorial/Sim2.txt 

http://familias.name/tutorial/Sim2.txt
http://familias.name/tutorial/Sim2.txt


Simulations and generating data – How to 
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• Alternative 1 – Pairwise relationships 
 

Open the frequency databse linked to in the first slide of this section. Then open the 
generate data feature through Tools -> Generate data. Use default settings but change 
the Relationship to Full siblings and select to compute both likelihood statistics. Press 
’Generate’. Note that the IBS statistics, i.e. shared segments and kinship coefficients do 
not work well with only two markers. The results will be saved to a file. Later we will 
show how to plot these data in R. 



5. Blind search and DVI 
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Input file: tutorial-Ch5.sav 

https://famlink.se/Files/tutorial-Ch5.sav
https://famlink.se/Files/tutorial-Ch5.sav
https://famlink.se/Files/tutorial-Ch5.sav


Blind search – purpose  

• Find the pairwise relationships between DNA profiles.  
– Simple case: 

 

 

 

 

 

 

• With the above profiles, we can do the following six comparisons 
– PM1-PM2, PM1-PM3, P2-P3, 

• ‘Blind’ implies that some fixed relationships are searched (as opposed to explicitly 
specifying pedigrees) namely 

– Parent-Child, Siblings, Half-siblings, Direct-match, Cousins, 2nd cousins 
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Blind search – How to 

1. Start by defining a marker and frequency database (see section 1. Basics). Import 
from file tutorial-Ch5.sav. 

2. Import the persons/samples (tutorial-Ch5_pm.txt) 
a) Tools -> Persons 
b) Press ’Import ’ 
c) ’Open file’ and import you data 

3. Open the blind search interface 
a) Tools -> Blind search 
b) Press ’New search’ 

4. Use the setting illustrated below. Search for Full sibling. 
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Blind search – How to 

6. The results are illustrated below 
 
 
 
 
 
 
 

7. Redo the search but select ’Grid search’ to find the most likely relationship. 
Results are illustrated below. 
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DVI illustrated 
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1. General DNA data 
Available from tutorial-Ch5.sav 

2. Unidentified samples:  
Three samples PM1, PM2 and PM3 and their 
genotypes. 

3. Reference family:  
One reference family representing a full sibling of a 
missing person 
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AM1 

PM1 

PM2 

PM3 

MP 



DVI– How to 

1. Start by defining a marker and frequency database (see section 1. Basics). Import 
from file tutorial-Ch5.sav. 
 

2. Next there are two alternatives since FamLink2 does not contain a fully 
comprehensive tools to perform DVI.  

 
Alternative 1 – Perform a pairwise blind search with all AM and PM profiles listed as 

samples. See the previous section about performing a blind search and import AM 
and PM samples in the same list of persons. 

 
Alternative 2 – Perform a targeted search where we first import all PM samples and 

then continue to perform a search for each family (AM) potentially using several 
relatives to identify a missing person. 
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DVI– How to 

Alternative 1 – Perform a pairwise blind search with all AM and PM profiles listed as 
samples. See the previous section about performing a blind search and import AM 
and PM samples in the same list of persons. 

 
1. Start by defining a marker and frequency database (see section 1. Basics). Import 

from file tutorial-Ch5.sav. 
2. Import the PM samples (tutorial-Ch5_pm.txt) 

a) Tools -> Persons 
b) Press ’Import ’ 
c) ’Open file’ and import you data (close the dialog once finished). Results should look like the 

illustration below. 
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DVI– How to 

Alternative 1 – Perform a pairwise blind search with all AM and PM profiles listed as 
samples. See the previous section about performing a blind search and import AM 
and PM samples in the same list of persons. 

 
1. Start by defining a marker and frequency database (see section 1. Basics). Import 

from file tutorial-Ch5.sav. 
2. Import the PM samples (tutorial-Ch5-pm.txt) 

a) Tools -> Persons 
b) Press ’Import ’ 
c) ’Open file’ and import you data (close the dialog once finished). Results should look like the 

illustration below. 

3. Import the AM sample (tutorial-Ch5-am.txt) 
a) Tools -> Persons 
b) Press ’Import ’ 
c) ’Open file’ and import you data (close the dialog once finished 

 
 
 
 
 
 

42 FamLink - Tutorial 



DVI– How to 

Alternative 1 – Perform a pairwise blind search with all AM and PM profiles listed as 
samples. See the previous section about performing a blind search and import AM 
and PM samples in the same list of persons. 

 
1. Start by defining a marker and frequency database (see section 1. Basics). Import 

from file tutorial-Ch5.sav. 
2. Import the PM samples (tutorial-Ch5-pm.txt) 

a) Tools -> Persons 
b) Press ’Import ’ 
c) ’Open file’ and import you data (close the dialog once finished). Results should look like the 

illustration below. 

3. Import the AM samples (tutorial-Ch5-am.txt) 
a) Tools -> Persons 
b) Press ’Import ’ 
c) ’Open file’ and import you data (close the dialog once finished). Results should look like the 

illustration below. 

4. Perform a blind search as described previously in this section. Use default values, 
deselect ‘Segment analysis’ as this is not relevant when only two markers are 
used. Select Full siblings from the list of relationships. Press ‘Search’. 
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DVI– How to 

The results when using Alternative 1 to perform a blind search among AM/PM 
samples. 
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DVI– How to 

Alternative 2 – Perform a targeted search where we first import all PM samples and 
then continue to perform a search for each family (AM) potentially using several 
relatives to identify a missing person. 

 
1. Start by defining a marker and frequency database (see section 1. Basics). Import 

from file tutorial-Ch5.sav. 
2. Import the PM samples (tutorial-Ch5-pm.txt) 

a) Tools -> Persons 
b) Press ’Import ’ 
c) ’Open file’ and import you data (close the dialog once finished). Results should look like the 

illustration below. 

3. Select the hypothesis through Tools -> Select pedigree. Use Full siblings as main 
hypothesis and press ‘Next’.  

4. Use Unrelated as the alternative hypothesis. Press ‘Next’. 
5. Import data for the single relative in the file tutorial-Ch5-am.txt. Import to one of 

the individuals in the pedigree, it does not matter to who since the pedigree is 
symmetrical. Press ‘Next’. 
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DVI– How to 

Alternative 2 – Perform a targeted search where we first import all PM samples and 
then continue to perform a search for each family (AM) potentially using several 
relatives to identify a missing person. 

 
6. Perform a targeted search by clicking the ’DVI search’ button. See illustration 

below. Select NN2 as the target (i.e. the missing person). Press ’Search’ to perform 
a search. Results are illustrated below. 
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DVI– How to 

The results when performing a targeted search, all PM profiles against one AM family. 
Note that this feature allows several reference AM family members! 
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6. Phenotype/Ancestry/Haplogroup 
predictions 
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Predictions 

• There is a tool to predict phenotype/ancestry and haplogroup (Y) using published 
methods. The tool is accessed through Tools -> Phenotype/Ancestry/Haplogroup 
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View details 

Options include to model genotype uncertainty (not fully implemented yet) as well as to 

 include only ancestry defined markers (see Database) 



Prediction details 

• Displays details about a prediction, see examples below. 
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Phenotype predictions 

• Uses the logistic model described for the HirisPlex data set 
– See Chaitanya et al. https://doi.org/10.1016/j.fsigen.2018.04.004  

• The model needs betas which can be freely accessed for eye and hair color 
following the above publications.  

– See the files xx that comes with the install of FamLink 

• We advice to create an export file (single or multiple samples) and run it through 
the HirisPlex website containing the most up-to-date reference data sets. 
https://hirisplex.erasmusmc.nl/  

• FamLink2 allows the user to run the analyses offline expect for the skin color 
prediction where betas are not published.  
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Ancestry predictions 

• Uses a Naive Bayes approach 
– Profile probabilities are estimated in each defined population for overlapping markers between 

populations 

– Non-overlapping markers are discarded 

• FamLink2  
– See the files xx that comes with the install of FamLink 

• A caveat with this approach is that if the true population is missing from the 
reference data set, the results from the analysis cannot be trusted. We refer to 
GenoGeographer (or similar software), FamLink2 provides output files. 
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Haplogroup predictions 

• Finds the haplogroup specific mutations 
– Lists the deepest haplogroup first with counts (mutations) for each haplogroup 

• FamLink2  
– Uses a file available from Ralf et al., downloaded from https://github.com/genid/Yleaf  

• We refer to the method i Yleaf for a more specific haplogroup assignment. 
https://pubmed.ncbi.nlm.nih.gov/29518227/  
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Predictions – How to 

Phenotype and Y predictions do not necessitates a pre-defined database since genetic 
markers are hard-coded. For ancestry estimations at least two different 
populations needs to be defined, as well as the genetic markers 

1. Define a frequency database, see Database section 
2. Import persons/samples 

a) Tools -> Persons and import data from your files 

3. Predict phenotype/ancestry/haplogroups 
a) Tools -> Phenotype/Ancestry/Haplogroup 
b) Press ’Predict’ 
c) Press View details to display specific details about the predictions 
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8. Input files (formats) 
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8.1 Database input 
 

56 FamLink - Tutorial 



57 FamLink - Tutorial 

This format is highly standardized and specifies the genetic positions of all 
markers in our database. To get cM positions there are different sources, 
one is located at http://compgen.rutgers.edu/rutgers_maps.shtml . The 
map file can include headers or not and must be tab-separated. 

Map file (.map) 
 

CHROMOSOME MARKER POSITION (cM) 

1 rs1234 1.2 

1 rs12345 3 

2 rs123456 3 

3 rs1234567 20 

3 rs12345678 23 

http://compgen.rutgers.edu/rutgers_maps.shtml
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The standard format is recognized by FamLink. Please note that marker 
positions must be manually configured when this import is performed.  

Standard (tab separated) 
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This format is describes the frequency of our genetic markers. The format is 
described below and also outlined at 
http://csg.sph.umich.edu/abecasis/merlin/tour/input_files.html . We 
provide some data later in this tutorial but also on https://famlink.se. 
Generally data is extracted from the 1000G project. The file must be tab-
separated with three columns.  

Freq file (.freq) 
 

M rs1234 

A G 0.2 

A T 0.8 

M rs12345 

A A 0.6 

A T 0.4 

http://csg.sph.umich.edu/abecasis/merlin/tour/input_files.html
https://famlink.se/


8.2 Case data input (samples) 
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Tab separated files are most easily created in Excel (or a similar tool) and 
saved as text file with tab separation. Below is an example of the format. 

Tab separated (horizontal) 
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FamLink can import data from the genotyper software Genemapper (or data 
on similar format). The format is described exactly below. 

Genemapper (vertical) 
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The variant calling format (vcf) is highly standardized and is the output from 
common variant callers. Can contain multiple samples and information on 
reads, genotype likelihoods etc. File must be tab-separated. Must contain 
a header starting with #CHROM. Samples start in column 10. Column 9 
must contain description of the sample genotype (e.g. GT:AD).  

vcf (vertical) 
 

#CHROM MARKER bp Sample 1 

1 rs1234 1.2 1/1:0,100 

1 rs12345 3 1/1:0,100 

 

2 rs123456 3 1/1:0,100 

 

3 rs1234567 20 1/1:0,100 

 

3 rs12345678 23 1/1:0,100 
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This format is not standardized per se. The output is obtained through using 
the ‘Identify known mutations’ workflow, with input gvf file. The format is 
vertical and one file per sample. 

CLC Genomic Workbench 
 

Chromosome Marker Base Count 

1 rs1234 A 0 

1 rs1234 C 2 

1 rs1234 G 100 

1 rs1234 T 120 



9. Output files and reports 
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9.1 Reports from FamLink 
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This is the standard output from FamLink, i.e.,  the so called FamLink report. 
It may be generated using different scopes, the simple containing only 
information about the LRs and pedigrees and the most extensive 
containing all information needed to reproduce the results. 

The file is actually generated as a txt file with the rtf extension and is 
therefore not a true rich text formatted file. 

rtf format 
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This format will generate a comma (semicolons) separated file (csv). Output 
is illustrated below.   

csv format 
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This format will generate a tab separated file. Output is illustrated below.   

tab format 
 



9.2 Other 
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Several dialogs/windows allow the export of the complete table of results, 
e.g. DVI search results. The output is simply a tab separated txt file that 
may be processed further in Excel or similar software.  

 
Those exports are self-explained. 

General output 
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Several dialogs/windows allow the export of summaries, i.e., the blind search 
module allows the user to generate a summary of the results from a 
search, as does the DVI search function. 

Summary reports 
 



10. Settings 
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There are some advanced options/settings in FamLink reached via  
File -> Settings, see illustration on next page. Some of the settings are 
intended for expert users. 

Description 
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Genotype likelihoods – Activate the possibility for uncertainty in genotypes. Inputs must be based on vcf or CLC formatted data with 
read counts for each allele. Sequencing/mapping error refers to a low value indicating the probability of a read with an allele 
different then the true ones. Sample specific error refers to the quality of the sample and is harder to estimate but is usually high 
for low quality samples. Enforce vcf likelihoods will use the likelihoods from the vcf file (for instance from GATK) in the probability 
model. NOTE, all these features should be used with caution. 

Parallelization – Available in future releases. Possibility to make computations in go in parallel across multiple CPU cores. 
Merlin option – Turn off/on computation with Merlin (for validation) as well as the path to Merlin 

New alleles – Settings when a new allele is detected on import of data.  
Advanced – Set the threshold and steps for pedigrees where mutations are modeled. We recommend to keep the defaults, e.g. 

Threshold=0.0001 and Steps=0. 



Useful links 
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Genetic maps 
-FORCE markers (autosomal markers) 
-KIntelligence (autosomal markers) 
 

Frequency data 
-FORCE markers (autosomal markers) 
-KIntelligence (autosomal markers) 

 
Databases (ready to use): 
-FORCE markers (autosomal markers) with frequency data from 1000G 
-KIntelligence markers (autosomal markers) with frequency data from 1000G 

 

https://famlink.se/Files/FORCE_genetic_map.map
https://famlink.se/Files/kintelligence_genetic_map.map
https://famlink.se/Files/FORCE_freq_files.zip
https://famlink.se/Files/kintelligence_freq_files.zip
https://famlink.se/Files/FORCE_famlink_project.sav
https://famlink.se/Files/kintelligence_famlink_project.sav
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