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Getting started - FamLink?2

This document describes how to get started using FamLink2. The document is based on version 2.3 of
FamLink but should also work reasonably well for any versions above 2.0. Please note that version 1.16
and below contain a completely different interface. We refer to FamLink as FamLink2 in this document
to distunguish from version 1.16 and below.

For a more comprehensive description and theory we refer to the complete tutorial available following
links at https://famlink.se.
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1 Defining a marker and frequency database

The first step is to define your markers and allele frequencies in one or more populations. Unless
importing from a FamLink project this is performed in a two-step manner. First, markers and their
genetic positions (measured in cM) are imported from a .map file. Accessed through File -> Frequency
database -> Import (see illustration below). We provide two such map files at

http://famlink.se/f download.html for the FORCE and Kintelligence panels. Please contact Andreas
Tillmar (andreas.tillmar@rmv.se) or Daniel Kling (Daniel.kling@rmv.se) for directions on how to obtain
cM positions for custom panels). Note, markers can also be manually defined, which is generally not
recommended besides for validation and exercise purposes. Second, allele frequencies are imported,
typically from a .freq file, for each population we want to include in our database. Again, accessed
through File -> Frequency database -> Import. We provide example files for the FORCE and Kintelligence
panels in the link given previously. Such Note, a FamLink project can contain any number of populations

which can easily be switched between from within the software. We can now save the project using File
-> Save which will create a FamLink project with markers and populations (in an xml-format). Next time
we only need to go through File -> Open project and import our database data.
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2 Defining hypotheses and import DNA data

The second step is to select the hypotheses or create the pedigrees. For simple pairwise comparisons,
see section 4 below. Selecting hypothesis is done through Tools -> Select pedigree. This lists a number
of pre-defined pedigrees with illustrations, see figure below.

Select basic hypothesis (Only cne pedigree) d
Grandparent Grandparents Duo Grandparents A Create/Edit
(data maother) Two unrelated pedigree
7 IE@- o ][|3 |]3 n (2 : n 7 Display full image
} ‘ = At
]
: 3 2
. . Import ped file
Three unrelated Unrelated Paternity Paternity
{data mothers) (trio) (duo)
i IBT,J [y o #
o] [ 1]
' ]
Incest (Data mother) Mo incest Incest First cousins
Great grandparent First cousins once Second cousins Second cousins once
removed removed v

Cloze Mext -=

FamLink also allows the creation of custom pedigrees through the ‘Create/Edit pedigree’ button.

Creating pedigrees is described in detail in the tutorial but follows a similar concept as creating
pedigrees in Familias. First persons are defined, next parent-child relations are defined. Plotting is
possible in R, described in the tutorial.

Once a main hypothesis has been selected press ‘Next’ to select an alternative hypothesis. Multiple
alternative hypotheses selection is possible (Press and hold Ctrl while selecting). Next, DNA data is
imported, preferebly from a file, but manual allele assignment is also possible.

Add DMA data X
Basic hypothesis [First cousins] Edit DNA data — | = | p—rw— | "
hd rs9442372 1 A, A
/ MName rs12142199 1
Kinshp Sampe A foswez 1 ot
Gender rso695131 1 cT
(* Male (" Female rs3765703 1 G T
rs73670606 1 c,C
Marker rss675979 1 G, A
- - rs11308641 1 A A
rs1490413 1
Alleles rs375307 1 G, G
,—_| ,—_| rs434504 1
rs21581599 1 TT
1 2 ] rs3128687 1 TG
[ Genotype uncertainty | | rs707582 1 A, A
rs29g6742 1
1 T.C ¥

Import data rs7535846
<-Prev Close Compare Next -
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Press ‘Import data’ to bring up the dialog displayed below. Press ‘Open file...” to select the file for
import. Note, multiple files cannot be imported simultanously.

Import DMA data
Column1 | Column2
rs9442372 AA
rs4043727 CC
rs10910082 cT
rsoe35131 CcT
rs37a5703 GT
rs7367066 CC
rsGa75a7e GA
rs11308641 AA
rsa3y5a07 GG
rs2131699 T
rs3123687 TG
rs 707532 AA
rs 7535346 TC
rs228729 TC
rs7529511 CC
rs10364411 TC
rs2433679 AA
rs205474 CcT

The vertical format is
generic and indicates ane
sample per column. The first
column should contain the
marker ids corresponding to
the imported database.

One row is equal to one

genotype

pod

Cpen file. ..

Impaort

Close

Select format

Vertical -

Select delimiter
TAB -

Allele

Mone -

[ Has header

Select the appropriate file format and delimiter as well as delimiter separating alleles, in the above

example none, i.e. genotypes are given as AA for instance. Press ‘Import’ to import the data and select

the individual to import data to.
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3 Computing likelihoods and further

Once DNA is imported, press ‘Next’ to perform likelihood computations. Press ‘Calculate’. Results are by
default given for the LR (Exact) and LR (Unlinked) methods. The former is the recommended method
developed for FamLink2 whereas the latter is used as comparison assuming all markers are unlinked.
See illustration below.

Results %
— Actions
: i A
- [ Calculate
= : DVI search
First cousins Unrelated
LR (Exact): Scale )
1.57594e+010 Simulate
LR (Unlinked): :
748472 Options
LR /Posterior
Scale
Set prior
View results
Save results

<-Prev Close

This dialog also allows a simple DVI search, described in detail in the Tutorial whereby a list of PM

profiles can be matched into a reference family. In addition simulating data is possible. Pressing 'View
results’ will bring up the dialog illustrated below with individual marker LRs. Caveat: The marginal LR is
the added LR for each marker, but is NOT equivalent to the LR obtained if that single marker is used for

calculations.

View data (Beta) >
Marker | chr | Position Accumulated LR | Marginal LR | Kinship 5... | Kinshi Marker
rs9q442372 1 1.08 1 1 A4 G |
rs12142199 1 1.31 1 1
rsd4648727 1 1.34 1.3 1.2 C,C C  Chromosome
rs10910082 1 2.499 1.3 1 C,T T
rs6695131 1 3.08 1.3 1 CT o All i
rs3765703 1 3.68 1.2 0.94 G,T T
rs7367066 1 3.89 1.4 1.2 C,C C
rsGG 75979 1 4,01 1.4 1 G4 G
rs11808641 1 4,19 1.6 1.2 A4 .

Contact: Daniel Kling daniel.kling@rmv.se




Getting started — FamLink2 Updated 10/18/2022

4 Importing DNA data

Importing DNA data can be performed various places in FamLink. The following section describes how to
import data for purposes other than regular hypothesis likelihood computations as described in section
2. Importing DNA data does not necessitates a marker and frequency database. Import is done without
checking the correspondance with what is defined in terms of genetic markers. A matching is rather
performed once any functions requiring a marker/frequency database is done. Tools -> Persons contains
a list of imported individuals. Through the ‘Import’ button the dialog below appears where one can
choose to browse for a file to import, ‘Open file...”. The contents will be displayed based on the options,
e.g. changing delimiter will change how FamLink interprets the file. Also allele delimiter can be changed.

Import DMA data ot

SHP Crime s... ~ The \.-'n_artic.?:: fﬂé!'na;:js Open file...
eneric and indicates one —— |

rs12142199 AA gample per column, The first Import
rs434504 A column should contain the ~——
rs29se74d T marker ids corresponding to Close
rs5541030 GG the imported database.
rsg47325 AL One row is equal to one Select format
rs4903343 AR genaotype Vertical -
rs1325502 GG
rs12130799 AA Select delimiter
rs3118378 AA TAB -
rs2139931 GA
rs3737576 T Allele
rs ?5 54’9 36 ':': NDFIE -
rs2814778 TT
rs4657449 GG [+ Has header
rs 1040404 GG
rs2227203 cT
rz1407434 GG
rs4351629 T -
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5 Phenotype/Ancestry/Haplogroup predictions

FamLink has a new feature to perform some rudimentary predictions. Ancestry predictions require a
frequency database to be defined with at least two populations, see section 1. First, import the
samples/persons you want to perform predictions on, use Tools -> Persons -> Import -> Open file, see
also section 4. Select your file and then press ‘Import’ to import the individuals and their DNA into the
software. Make sure to select the correct setting for the import. Next, access the prediction tools
through Tools -> Phenotype/Ancestry/Haplogroup. Press 'Predict’ and select a results and press 'View
details’ to explore the details of a prediction, see illustrations below.

Predictions X

Static

Sample | Y haplogroup (deepe... | Eye color | Hair color | ‘ Ancestry | Predict
SNPdata_part2_3 Sa... Riblaiblzlalc2al;.. Blue (0.858155) Blond {0.7012... FORCE_EUR (1,000000)
Al -
Select export,
Prediction details X Indude al
[ markers in
Prediction/Ancestry/Haplogroup | Probability,Count | ~ Samples ancestry
RiblatblalalcZal 5.000000 [stPpdata_partz_3 ~ | - Model
Rihiathlalalc 3.000000 ) genotype
Riblathialst 2.000000 Predicton uncertainty
Riblathlala 3.000000 Y haplogroup v e
Ribiaibial 1.000000 _—
Ribiaibia 2.000000 Export
Ribiaib 4.000000 |
Ribial 1.000000 B
Ribia 2.000000 Report
Rib 1.000000
R1 1.000000
R 1.000000
P1 1.000000
P 2.000000
K2b 1.000000
K2 2.000000
K 3.000000
LK 1000000 Export
HIIK 2.000000
F 2.000000 Close
cT 1.000000 w
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6 Blind search

FamLink has a new feature that allows blind searching. Briefly, a blind search is performed for a set of

Updated 10/18/2022

samples/individuals to identify unknown relationships. An example is a set of PM samples from a DVI

scenario where one wishes to establish
relatives in the data set. Other application
could be two samples where one wishes to
find the most likely relationship. First, we
need to define marker and frequency
database, see section 1. Next we import the
samples we wish to use in the blind search.
Tools -> Persons -> Import. Open file to
browse to your file and import. The blind
search tool is accessed through Tools -> Blind
search. Press ‘New search’ which will bring
up the dialog illustrated to the right.

The blind search allows several settings. One
may perform a segment search where half-

Search options 4
Likelihood computations
¥ Activate LR threshold Relationship__| kappas |~ St F
v i 0.000000 Parentfchld  0/1/0 Close i
¥ Account for inkage Full siblings 0.25/0.5/0.25
I~ Grid search Kinship fFst Half siblings 0.5/0.5/0
™ Most likel - 0 First cousins 0.75/0.25/0
A E A First cousins ... 0.875/0,125/0
™ Use genotype likelihoods Second cousins  0.9375/0.0625/0
Grandparent 0.5/0.5/0
Great arando.., 0.75/0,25/0 b

Briefly, the Likelihood search uses fast iterators to compute the likelihoods and LRs for
the selected relationship and settings specified. Mote that mutations are only considered
for parent/child relationship. Settings indude. ..

Segment analysiz
cM threshold

| 5,000

#SNP threshold #Errors allowed

|1n |o

[~ Calculate density
Briefly, the IBD/Segment search uses fast iterators to compute some IBD and IBS
metrics for each comparison. Settings indude the minimum segment length (in cM), the
minimum number of SMPs (in integer) and the errors allowed in a segment {in integer)

[v Activate

identical segments are identified. On the other hand, one may compute the likelihood for each

comparison for a selection of relationships (see the illustration above). The 'Grid search’ options forces

FamLink2 to compute the likelihood for all relationships in the list and report the most likely. The
’Account for linkage’ option (default activated) makes FamLink account for linkage in the likelihood

computations. Deactivting this feature is not recommended for denser marker panels, say >100. The

'Grid search’ is performed slightly differently when linkage is not accounted for, then a grid of IBDO,
IBD1 and IBD2 coefficients are explored and the most likely reported. The ‘"Most likely population’
option is not currently implemented. The 'Use genotype likelihood’ option is not fully described but

allows the use of sequence read data, either imported through a vcf file or through a CLC like file, to

model possible genotypes, in contrast to exactly importing an exact genotype. Feature will be described

in detail in the next version of FamLink?2.

Press ‘Search’ and be patient, the search may take a while if there are many samples involved and in

particular if the ‘Grid search’ is activated. Example of results is illustrated below.
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Blind search *
Mumber of profiles: 9 Mumber of matches: 36 Population used:
Profile1 | Profile2 Markers used LR Posterior Relationship | Total seg... | Largestse... | Total seg... 14 | Mew search
DVI -PM1 DVI - PM2 3931 5.12%e-00%9 5.129e-009  First cousins 1450.95 51.94 97 0.1 D —
DVI -PM1 DVI -PM3 3931 0.0008502 0.0008495  First cousins 1663.70 57.72 113 0.C JEE——
DVI -PM1 DVI - PM4 3931 4,883e-010 4.883e-010  First cousins 1435.86 58,10 108 0.1 View match
DVI -PM1 DVI - AM1 3931 8.153e-008  B8.153e-008  First cousins 1495.80 45.19 105 0.1
DVI -PM1 DVI - AM2 3931 1.654e-010 1.654e-010  First cousins 1447.63 56,78 97 0.1
DVI -PM1 DVI - AM3 3931 4.025e-008  4.025e-008  First cousins 1589.22 74.07 99 0.1
DVI -PM1 DVI - AM4 3931 l442e+012 1 First cousins 1780.54 104.15 95 0.
DVI -PM1 DVI - AMS 3931 1.816e-007 1.816e-007  First cousins 1562.61 58.26 109 0.C
DVI -PM2 DVI - PM3 3931 1,555e-008 1,555e-008  First cousins 1469.73 52.26 107 0.1
DVI -PM2 DVI - PM4 3931 4e-008 4e-008 First cousins 1498.13 50.45 107 0.1
DVI -PM2 DVI - AM1 3931 1.465e+038 1 First cousins 1901.89 110,23 95 0.
DVI -PM2 DVI - AM2 3931 2.544e-010 2.549e-010  First cousins 1398.30 38.88 111 0.1
DVI -PM2 DVI - AM3 3931 3. 22%9e-009 3.229e-009  First cousins 1474.96 60,51 102 0.1
DVI -PM2 DVI - AM4 3931 5.775e-009  6.776e-009  First cousins 1529.45 87.91 97 0.1
DVI -PM2 DVI - AMS5 3931 3.008e-007  3.008e-007  First cousins 1639.63 66,14 107 0.1
DVI -PM3 DVI - PM4 3931 4.083e-007  4.083e-007  First cousins 1606.45 53.07 119 0.1
DVI -PM3 DVI - AM1 3931 0.00018 0.00013 First cousins 1565.05 45.48 110 0.1
DVI -PM3 DVI - AM2 3931 1.424e-007 1.424e-007  First cousins 1357.28 41.22 105 0.1
DVI -PM3 DVI - AM3 3931 1.69%e+042 1 First cousins 1788.75 88.43 91 0.cw
€ > Export

Close
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7 Generate data and simulations

To generate data and compute summary statistics we refer to the next version of FamLink. The current
release contains two functions to generate data. One is found through Tools -> Generate data with
several options for generating data for pairwise relationships. See illustration below, with several
options for generating data (Ancestry settings and Advanced settings) as well as analysing the generated
data (Computations).

Generate data pd
General settings
Mumber of profiles Seed Generate
1000 12345
Close

[ Save toproject W Save to file

Ancestry settings

Population 1 Population 2
|FORCE_EUR ~| | =]
| Use theta/Fst [ Mixed founders

Advanced settings

Relationship
|First Cousing j [ Use mutations

Dropout prob. Dropin prob.  Error prob.
0 E 0

Computations
[ Perform likelihood computations
[ Compute IBS metrics

The other alternative, which is more general for any relationship and number of typed individuals, is
through the Tools -> Results feature where ‘Simulate data’ is available. The latter has not been
completely tested yet. More information on simulation will be available soon.

Contact: Daniel Kling daniel.kling@rmv.se




Getting started — FamLink2 Updated 10/18/2022

8 Advanced settings

To access settings go through File -> Settings. See below. Note, activating the ‘Debug mode’ will force
FamLink2 to output several debug files during run that may slow the software but will allows the user to
send data when bugs are detected.

Settings x
Simple settings e
Genotype likelihoods Parallelization Pedigree | Threshold | Steps | Lump alleles Create
[ Activate [~ Activate Full Siblings(data mother) 0.0001 0 Yes =
Sequendng/mapping error Half Siblings{data mother) 0.0001 1] Yes
Number of cores (CPU) Full Siblings 0.0001 0 Yee ]
0 Half Siblings 0.0001 0 Yas [Iﬁglgag
Sample specific error Unrelated ) 0.0001 0 Ves
Merlin settings Half Siblings{data different m... 10,0001 o] Yes
™ Activate MERLIN Half Slbllng_sd!f'ferent mothers 10,0001 0 Yes
Pl e e Three full siblings 0.0001 1] Yes
MERLIM temp path Two full siblings and one halfsi... 0.0001 [u} Yes
I~ Enforce vcf likelihoods | D:\Dropbox\DevelopmentFamLink_2_ Two full siblings and one half si... 0.0001 0 Yes
Twao full siblings and one unrela... 0.0001 o] Yes
New alleles File path Unde(data mother) 10,0001 0 Yes
linda N nnnit n Var
I” Remember settings |SE|ECt file... ﬂ
New allele freq, | Change parameters

Threshold
0.010000 Report options ,7
v Indude frequency database
™ Debug mode ¥ Indude casa DNA data Steps (Transitions)

[+ Indude marker spedfic LR Update

™ Lump alleles Update all
Close 1
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